大家都在找

区分顶底背离副图指标公式源码

副图一分为二,上为顶背离区,下为底背离区,并且都有背离文字标识,这样一目了然 底:-50; 顶:50; TRR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-R…

副图一分为二,上为顶背离区,下为底背离区,并且都有背离文字标识,这样一目了然
底:-50;
顶:50;
TRR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
PDI:= PDM*100/TRR;
MDI:= MDM*100/TRR;
A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF"(12,26,9),A1+1)<"MACD.DIF"(12,26,9) AND CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9));
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9)),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF"(12,26,9),C1+1)>"MACD.DIF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9));
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
C4:=BARSLAST(REF(CROSS(MDI,PDI),1));
D4:=REF(C,C+1)<C AND REF(MDI,C4+1)>MDI AND CROSS(MDI,PDI);
A4:=BARSLAST(REF(CROSS(PDI,MDI),1));
B4:=REF(C,A4+1)>C AND REF(PDI,A4+1)<PDI AND CROSS(PDI,MDI);
DMI底背:IF(B4>0,-50,0),COLOR0099FF,POINTDOT;
DRAWTEXT(B4>0,-5,’DMI底背’),COLOR0099FF;
DMI顶背:IF(D4>0,50,0),COLORBLUE,POINTDOT;
DRAWTEXT(D4>0,15,’DMI顶背’),COLORBLUE;
MACD底背:IF(B1>0,-50,0),COLORRED,POINTDOT;
DRAWTEXT(B1>0,-15,’MACD底背’),COLORRED;
KDJ底背:IF(B2>0,-50,0),COLORFF00FF,POINTDOT;
DRAWTEXT(B2>0,-25,’KDJ底背’),COLORFF00FF;
RSI底背:IF(B3>0,-50,0),COLORYELLOW,POINTDOT;
DRAWTEXT(B3>0,-35,’RSI底背’),COLORYELLOW;
MACD顶背:IF(D1>0,50,0),COLOR00FF00,POINTDOT;
DRAWTEXT(D1>0,25,’MACD顶背’),COLOR00FF00;
KDJ顶背:IF(D2>0,50,0),COLORFFCC66,POINTDOT;
DRAWTEXT(D2>0,35,’KDJ顶背’),COLORFFCC66;
RSI顶背:IF(D3>0,50,0),COLORFFFFFF,POINTDOT;
DRAWTEXT(D3>0,45,’RSI顶背’),COLORFFFFFF;
STICKLINE(B1>0,-50,0,0,0),COLORRED;
STICKLINE(B2>0,-50,0,0,0),COLORFF00FF;
STICKLINE(B3>0,-50,0,0,0),COLORYELLOW;
STICKLINE(D1>0,50,0,0,0),COLOR00FF00;
STICKLINE(D2>0,50,0,0,0),COLORFFCC66;
STICKLINE(D3>0,50,0,0,0),COLORWHITE;
STICKLINE(B4>0,-50,0,0,0),COLOR0099FF;
STICKLINE(D4>0,50,0,0,0),COLORBLUE;

淘股吧公众号
扫码关注微信公众号

每天必更

作者: taoguba

为您推荐

发表评论

电子邮件地址不会被公开。 必填项已用*标注

联系我们

联系我们

在线咨询: QQ交谈

       

邮箱: 313707241@qq.com

工作时间:周一至周五,9:00-17:30,节假日休息

关注微信
微信扫一扫关注我们

微信扫一扫关注我们

返回顶部